import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?:(?:img)(?=[\\s>\\/])(?:[^>=]|=(?:'[^']*'|\"[^\"]*\"|[^'\"\\s>]*))*\\s?\\/?>|(a|span|pre|code|strong|b|em|i)(?=[\\s>\\\\])(?:[^>=]|=(?:'[^']*'|\"[^\"]*\"|[^'\"\\s>]*))*\\s?\\/?>.*?<\\/\\1>)|(?:\"[^\"]*\"|[^\"<]*)*";
final String string = "<b>test</b> or <strong> this </strong><em> oh yeah </em> and <i>oh yeah</i> Here we are \"ye we 'hold' it\"\n\n"
+ "some<img/>gfsf<a html=\"droids.html\" onmouseover=' var x=\" Not the droid I am looking for \" ; '>droides</a><pre></pre><code></code><strong></strong><b></b><em></em><i></i>";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}