# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
<(?:(?:img)(?=[\s>\/])(?:[^>=]|=(?:'[^']*'|"[^"]*"|[^'"\s>]*))*\s?\/?>|(a|span|pre|code|strong|b|em|i)(?=[\s>\\])(?:[^>=]|=(?:'[^']*'|"[^"]*"|[^'"\s>]*))*\s?\/?>.*?<\/\1>)|(?:"[^"]*"|[^"<]*)*
"""
test_str = ("<b>test</b> or <strong> this </strong><em> oh yeah </em> and <i>oh yeah</i> Here we are \"ye we 'hold' it\"\n\n"
"some<img/>gfsf<a html=\"droids.html\" onmouseover=' var x=\" Not the droid I am looking for \" ; '>droides</a><pre></pre><code></code><strong></strong><b></b><em></em><i></i>")
subst = "$1$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL | re.IGNORECASE | re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.