const regex = /<(?:(?:img)(?=[\s>\/])(?:[^>=]|=(?:'[^']*'|"[^"]*"|[^'"\s>]*))*\s?\/?>|(a|span|pre|code|strong|b|em|i)(?=[\s>\\])(?:[^>=]|=(?:'[^']*'|"[^"]*"|[^'"\s>]*))*\s?\/?>.*?<\/\1>)|(?:"[^"]*"|[^"<]*)*/gsi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?:(?:img)(?=[\\s>\\\/])(?:[^>=]|=(?:\'[^\']*\'|"[^"]*"|[^\'"\\s>]*))*\\s?\\\/?>|(a|span|pre|code|strong|b|em|i)(?=[\\s>\\\\])(?:[^>=]|=(?:\'[^\']*\'|"[^"]*"|[^\'"\\s>]*))*\\s?\\\/?>.*?<\\\/\\1>)|(?:"[^"]*"|[^"<]*)*', 'gsi')
const str = `<b>test</b> or <strong> this </strong><em> oh yeah </em> and <i>oh yeah</i> Here we are "ye we 'hold' it"
some<img/>gfsf<a html="droids.html" onmouseover=' var x=" Not the droid I am looking for " ; '>droides</a><pre></pre><code></code><strong></strong><b></b><em></em><i></i>`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);