using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"iframe\s*(?:\s|width=""(.*?)""|height=""(.*?)"")+src=""(.*?www\.stackoverflow\.com\/share(?:\/.*?)?)""";
string input = @"<iframe height=""100"" width=""200"" src=""https://www.youtube.com/share""></iframe>
<iframe height=""100"" width=""200"" src=""https://www.youtube.com/share/xxx""></iframe>
<iframe height=""100"" width=""200"" src=""https://www.stackoverflow.com/share/xxx""></iframe>
<iframe height=""100"" width=""200"" src=""https://www.stackoverflow.com/share""></iframe>
<iframe height=""100"" width=""200"" src=""https://www.google.com/share""></iframe>
<iframe height=""100"" width=""200"" src=""https://www.google.com/share/xxx""></iframe>
<iframe height=""100"" width=""200"" src=""https://www.yahoo.com/share""></iframe>
<iframe height=""100"" width=""200"" src=""https://www.yahoo.com/share/xxx""></iframe>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}