const regex = /iframe\s*(?:\s|width="(.*?)"|height="(.*?)")+src="(.*?www\.stackoverflow\.com\/share(?:\/.*?)?)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('iframe\\s*(?:\\s|width="(.*?)"|height="(.*?)")+src="(.*?www\\.stackoverflow\\.com\\\/share(?:\\\/.*?)?)"', 'g')
const str = `<iframe height="100" width="200" src="https://www.youtube.com/share"></iframe>
<iframe height="100" width="200" src="https://www.youtube.com/share/xxx"></iframe>
<iframe height="100" width="200" src="https://www.stackoverflow.com/share/xxx"></iframe>
<iframe height="100" width="200" src="https://www.stackoverflow.com/share"></iframe>
<iframe height="100" width="200" src="https://www.google.com/share"></iframe>
<iframe height="100" width="200" src="https://www.google.com/share/xxx"></iframe>
<iframe height="100" width="200" src="https://www.yahoo.com/share"></iframe>
<iframe height="100" width="200" src="https://www.yahoo.com/share/xxx"></iframe>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}