// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"iframe\s*(?:\s|width="(.*?)"|height="(.*?)")+src="(.*?www\.stackoverflow\.com\/share(?:\/.*?)?)""#).unwrap();
let string = "<iframe height=\"100\" width=\"200\" src=\"https://www.youtube.com/share\"></iframe>
<iframe height=\"100\" width=\"200\" src=\"https://www.youtube.com/share/xxx\"></iframe>
<iframe height=\"100\" width=\"200\" src=\"https://www.stackoverflow.com/share/xxx\"></iframe>
<iframe height=\"100\" width=\"200\" src=\"https://www.stackoverflow.com/share\"></iframe>
<iframe height=\"100\" width=\"200\" src=\"https://www.google.com/share\"></iframe>
<iframe height=\"100\" width=\"200\" src=\"https://www.google.com/share/xxx\"></iframe>
<iframe height=\"100\" width=\"200\" src=\"https://www.yahoo.com/share\"></iframe>
<iframe height=\"100\" width=\"200\" src=\"https://www.yahoo.com/share/xxx\"></iframe>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}