import re
regex = re.compile(r"iframe\s*(?:\s|width=\"(.*?)\"|height=\"(.*?)\")+src=\"(.*?www\.stackoverflow\.com\/share(?:\/.*?)?)\"")
test_str = ("<iframe height=\"100\" width=\"200\" src=\"https://www.youtube.com/share\"></iframe>\n"
"<iframe height=\"100\" width=\"200\" src=\"https://www.youtube.com/share/xxx\"></iframe>\n\n"
"<iframe height=\"100\" width=\"200\" src=\"https://www.stackoverflow.com/share/xxx\"></iframe>\n"
"<iframe height=\"100\" width=\"200\" src=\"https://www.stackoverflow.com/share\"></iframe>\n\n"
"<iframe height=\"100\" width=\"200\" src=\"https://www.google.com/share\"></iframe>\n"
"<iframe height=\"100\" width=\"200\" src=\"https://www.google.com/share/xxx\"></iframe>\n\n"
"<iframe height=\"100\" width=\"200\" src=\"https://www.yahoo.com/share\"></iframe>\n"
"<iframe height=\"100\" width=\"200\" src=\"https://www.yahoo.com/share/xxx\"></iframe>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")