# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s+?(\d{3})(?=-)/ (\1)/gm;t' <<< "My phone number is 999-582-9090"