import Foundation
let pattern = #"\s+?(\d{3})(?=-)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"My phone number is 999-582-9090"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" (\1)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)