$re = '/\s+?(\d{3})(?=-)/m';
$str = 'My phone number is 999-582-9090';
$subst = " (\1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;