use strict;
my $str = 'My phone number is 999-582-9090';
my $regex = qr/\s+?(\d{3})(?=-)/mp;
my $subst = ' (\\1)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";