using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""[^""\r\n\\]*(?:"".[^""\r\n\\]*)*\""";
string substitution = @"";
string input = @"hola ""soy "" un tio ""pepiño""
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}