import re
regex = re.compile(r"\"[^\"\"\r\n\\]*(?:\"\".[^\"\"\r\n\\]*)*\"", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("hola \"soy \"\" un tio \"pepiño\"\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)