package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\"[^""\r\n\\]*(?:"".[^""\r\n\\]*)*\"`)
var str = `hola "soy "" un tio "pepiño"
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}