using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<div class=""layout""\>(?:.*?(?:<div).*?(?:<\/div>).*?){0,}<\/div>)";
string input = @"#{if(total,0)}#{else}
<div id=""recommend"">
<div class=""title""><p>Title</p></div>
#{item(1,5)}
<div class=""layout"">
<div class=""item"">
<a href=""#{url}""><img border=""0"" alt=""#{name}"" src=""#{image}""></a>
</div>
<div class=""goods"">
<a href=""#{url}"">#{truncate(name,27)}</a>
</div>
<div class=""price"">#{comma(price_tax)}</div>
</div>
#{/item}
<br clear=""all"">
</div>
#{/if}";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}