package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(<div class="layout"\>(?:.*?(?:<div).*?(?:<\/div>).*?){0,}<\/div>)`)
var str = `#{if(total,0)}#{else}
<div id="recommend">
<div class="title"><p>Title</p></div>
#{item(1,5)}
<div class="layout">
<div class="item">
<a href="#{url}"><img border="0" alt="#{name}" src="#{image}"></a>
</div>
<div class="goods">
<a href="#{url}">#{truncate(name,27)}</a>
</div>
<div class="price">#{comma(price_tax)}</div>
</div>
#{/item}
<br clear="all">
</div>
#{/if}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}