$re = '/(<div class="layout"\>(?:.*?(?:<div).*?(?:<\/div>).*?){0,}<\/div>)/s';
$str = '#{if(total,0)}#{else}
<div id="recommend">
<div class="title"><p>Title</p></div>
#{item(1,5)}
<div class="layout">
<div class="item">
<a href="#{url}"><img border="0" alt="#{name}" src="#{image}"></a>
</div>
<div class="goods">
<a href="#{url}">#{truncate(name,27)}</a>
</div>
<div class="price">#{comma(price_tax)}</div>
</div>
#{/item}
<br clear="all">
</div>
#{/if}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);