import re
regex = re.compile(r"(<div class=\"layout\"\>(?:.*?(?:<div).*?(?:<\/div>).*?){0,}<\/div>)", flags=re.DOTALL)
test_str = ("#{if(total,0)}#{else}\n"
"<div id=\"recommend\">\n"
" <div class=\"title\"><p>Title</p></div>\n"
" #{item(1,5)}\n"
" <div class=\"layout\">\n"
" <div class=\"item\">\n"
" <a href=\"#{url}\"><img border=\"0\" alt=\"#{name}\" src=\"#{image}\"></a>\n"
" </div>\n"
" <div class=\"goods\">\n"
" <a href=\"#{url}\">#{truncate(name,27)}</a>\n"
" </div>\n"
" <div class=\"price\">#{comma(price_tax)}</div>\n"
" </div>\n"
" #{/item}\n"
" <br clear=\"all\">\n"
"</div>\n"
"#{/if}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")