# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(select)(\s)(-)/\t\3/i;t' <<< "select 9-7 from test"