use strict;
my $str = 'select 9-7 from test';
my $regex = qr/(select)(\s)(-)/ip;
my $subst = '\\t\\3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";