using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(select)(\s)(-)";
string substitution = @"\t\3";
string input = @"select 9-7 from test";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}