import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "lat\\W+()(?=\\d+\\W+\\d+\\W+\\d+.\\d+)";
final String string = "[231] \"Lat.41 41' 19.09\\\" Long.-75 55' 19.51\\\"\" \n"
+ "[232] \"Lat. 41-41-22.13 Long. -75-59-17.29\" ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}