re = /lat\W+()(?=\d+\W+\d+\W+\d+.\d+)/mi
str = '[231] "Lat.41 41\' 19.09\\" Long.-75 55\' 19.51\\""
[232] "Lat. 41-41-22.13 Long. -75-59-17.29" '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end