# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\()[^\(\]]+(?=\))//g;t' <<< "NuimoIOS (_TtC8NuimoIOS9AppDevice) [sdfsdf]"