import re
regex = re.compile(r"(?<=\()[^\(\]]+(?=\))")
test_str = "NuimoIOS (_TtC8NuimoIOS9AppDevice) [sdfsdf]"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)