re = /(?<=\()[^\(\]]+(?=\))/
str = 'NuimoIOS (_TtC8NuimoIOS9AppDevice) [sdfsdf]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result