$re = '/(?<=\()[^\(\]]+(?=\))/';
$str = 'NuimoIOS (_TtC8NuimoIOS9AppDevice) [sdfsdf]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;