#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\+?(?:00)?\d{12}(?:#\d{2,5})?$"
Local $sString = "+919986040933" & @CRLF & _
"00919986040933" & @CRLF & _
"+919986040933#12" & @CRLF & _
"+919986040933#123" & @CRLF & _
"+919986040933#1234" & @CRLF & _
"+919986040933#12345"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")