package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+?(?:00)?\d{12}(?:#\d{2,5})?$`)
var str = `+919986040933
00919986040933
+919986040933#12
+919986040933#123
+919986040933#1234
+919986040933#12345`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}