const regex = /^\+?(?:00)?\d{12}(?:#\d{2,5})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+?(?:00)?\\d{12}(?:#\\d{2,5})?$', 'gm')
const str = `+919986040933
00919986040933
+919986040933#12
+919986040933#123
+919986040933#1234
+919986040933#12345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}