$re = '/^\+?(?:00)?\d{12}(?:#\d{2,5})?$/m';
$str = '+919986040933
00919986040933
+919986040933#12
+919986040933#123
+919986040933#1234
+919986040933#12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);