package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"category":(\[.*?\])`)
var str = `{"device_types":["smartphone"],"isps":["a","B"],"network_types":[],"countries":[],"category":["Jebb","Bush","qwe","asd","zxc"],"carriers":[],"exclude_carriers":[]}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}