import Foundation
let pattern = #""category":(\[.*?\])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"{"device_types":["smartphone"],"isps":["a","B"],"network_types":[],"countries":[],"category":["Jebb","Bush","qwe","asd","zxc"],"carriers":[],"exclude_carriers":[]}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}