const regex = /"category":(\[.*?\])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"category":(\\[.*?\\])', '')
const str = `{"device_types":["smartphone"],"isps":["a","B"],"network_types":[],"countries":[],"category":["Jebb","Bush","qwe","asd","zxc"],"carriers":[],"exclude_carriers":[]}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}