using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bconfig(\.[\w]+)*\.json\b";
string substitution = @"";
string input = @"This is config.json file
The stage config.staging.json file
The anything config.anything.json file
The mulit config.any.thing.json file
This is config.jsonot file
config..json";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}