import re
regex = re.compile(r"\bconfig(\.[\w]+)*\.json\b", flags=re.IGNORECASE)
test_str = ("This is config.json file\n"
"The stage config.staging.json file\n"
"The anything config.anything.json file\n"
"The mulit config.any.thing.json file\n"
"This is config.jsonot file\n"
"config..json")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)