const regex = /\bconfig(\.[\w]+)*\.json\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bconfig(\\.[\\w]+)*\\.json\\b', 'gi')
const str = `This is config.json file
The stage config.staging.json file
The anything config.anything.json file
The mulit config.any.thing.json file
This is config.jsonot file
config..json`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);