re = /\bconfig(\.[\w]+)*\.json\b/i
str = 'This is config.json file
The stage config.staging.json file
The anything config.anything.json file
The mulit config.any.thing.json file
This is config.jsonot file
config..json'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result