using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:met .*?(?=(?:(?:\d+\/)?\d+\w ?)))|(?:(?:\d+\/)?\d+\w ?)|(?:\d+ ?in ?\d+)";
string input = @"1/4w 1/4s 1/4w 1/4d 3 in 1 1% led met interne weerstand 1/4w";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}