const regex = /(?:met .*?(?=(?:(?:\d+\/)?\d+\w ?)))|(?:(?:\d+\/)?\d+\w ?)|(?:\d+ ?in ?\d+)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:met .*?(?=(?:(?:\\d+\\\/)?\\d+\\w ?)))|(?:(?:\\d+\\\/)?\\d+\\w ?)|(?:\\d+ ?in ?\\d+)', 'gi')
const str = `1/4w 1/4s 1/4w 1/4d 3 in 1 1% led met interne weerstand 1/4w`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}