using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:leaflet|mapbox)[\w\-\._]*(?:-script)?";
string input = @"id=""leaflet""
id=""mapbox""
id=""leaflet-script""
id=""mapbox-script""
id=""leaflet-0.7.2-script""
id=""webmap-leaflet-0.7.2""
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}