// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:leaflet|mapbox)[\w\-\._]*(?:-script)?").unwrap();
let string = "id=\"leaflet\"
id=\"mapbox\"
id=\"leaflet-script\"
id=\"mapbox-script\"
id=\"leaflet-0.7.2-script\"
id=\"webmap-leaflet-0.7.2\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}