const regex = /(?:leaflet|mapbox)[\w\-\._]*(?:-script)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:leaflet|mapbox)[\\w\\-\\._]*(?:-script)?', 'g')
const str = `id="leaflet"
id="mapbox"
id="leaflet-script"
id="mapbox-script"
id="leaflet-0.7.2-script"
id="webmap-leaflet-0.7.2"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}