package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:leaflet|mapbox)[\w\-\._]*(?:-script)?`)
var str = `id="leaflet"
id="mapbox"
id="leaflet-script"
id="mapbox-script"
id="leaflet-0.7.2-script"
id="webmap-leaflet-0.7.2"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}