package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+)?\s*\bcite\b\s*(\w+)?`)
var str = `cite any cases or other legal materials that cite the arbitrator should read before the hearing attachments cite`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}