import re
regex = re.compile(r"""
^"([0-9]{2})","([0-9]{5})","([a-z]{2})"
""", flags=re.MULTILINE | re.IGNORECASE | re.VERBOSE)
test_str = ("\"01\",\"35005\",\"AL\",\"ADAMSVILLE\",86.959727,33.588437,10616,0.002627\n"
"\"05\",\"72001\",\"AR\",\"ADONA\",92.903325,35.046956,494,0.00021\n"
"\"06\",\"90804\",\"CA\",\"SIGNAL HILL\",118.155187,33.782993,36092,0.001213")
subst = "$1chat/$2"
result = regex.sub(subst, test_str)
if result:
print(result)