// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mix)^"([0-9]{2})","([0-9]{5})","([a-z]{2})""#).unwrap();
let string = "\"01\",\"35005\",\"AL\",\"ADAMSVILLE\",86.959727,33.588437,10616,0.002627
\"05\",\"72001\",\"AR\",\"ADONA\",92.903325,35.046956,494,0.00021
\"06\",\"90804\",\"CA\",\"SIGNAL HILL\",118.155187,33.782993,36092,0.001213";
let substitution = "$1chat/$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}