using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\"")?(?:\w+(?:\.|\_|\<)?)+\w+(?:\"")?@(?:\w+\.)+\w{2,}(?:\>)?$";
string input = @"john@something.com
john.doe_@yahoo.com
""john.doe""@gmail.com
John_Doe_<johnDoe@something.net>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}