re = /^(?:\")?(?:\w+(?:\.|\_|\<)?)+\w+(?:\")?@(?:\w+\.)+\w{2,}(?:\>)?$/m
str = 'john@something.com
john.doe_@yahoo.com
"john.doe"@gmail.com
John_Doe_<johnDoe@something.net>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end