import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\\")?(?:\\w+(?:\\.|\\_|\\<)?)+\\w+(?:\\\")?@(?:\\w+\\.)+\\w{2,}(?:\\>)?$";
final String string = "john@something.com\n"
+ "john.doe_@yahoo.com\n"
+ "\"john.doe\"@gmail.com\n"
+ "John_Doe_<johnDoe@something.net>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}